PCPartPicker

  • Log In
  • Register

Build

Grawp

by noseonarug17

11
8 Comments

Details

Date Published

July 27, 2016

Date Built

July 26, 2016

CPU Clock Rate

4.4GHz

GPU Core Clock Rate

1.05GHz

GPU Effective Memory Clock Rate

1.0GHz

Description

This is my reddit browsing and gaming machine, and I'm so glad it's finally done after about 2.5 weeks (thanks, AMD). I initially planned to get an aftermarket 480, but after waiting forever (well, about a week and a half after finishing the initial build) I stumbled upon a newegg deal and got a Nitro Fury for $275. It's cutting it a bit close with the PSU but I still come in well under 550, and I've undervolted the Fury a bit to help.

The initial build (didn't include the HDD or GPU) went pretty well. The only physically difficult things were getting the motherboard in - it was a bit tighter fit than I'd have liked - and installing the radiator, which was stubborn and cramped behind the motherboard; I should have put that in beforehand. I also got a little confused by the little debug error code display thing on the motherboard (handy tool) - it shows a code when in the UEFI for some reason and I hadn't connected it to my monitor yet (I was going to wait for it to post first). That only took a couple minutes to figure out, though, and the only lasting issue was terrible cable management. That's harder than I thought. Oh, also, one of the contacts on the power button came off when removing the top panel, so I just hooked up the reset button to where the power button should be and use that instead. Works fine.

It turned out to be hard to see into the case without lighting, and the small LEDs on the case fans, cooler, and mobo didn't do much, so I decided to get an NZXT Hue+ on sale (I didn't include it in the price because it's purely aesthetic, which to me makes it a peripheral). That was pretty easy aside from having to install it with the ports facing into the case, as the connectors were a bit long and wouldn't have fit the other way. Since the window is sort of a truncated triangle, I only used 3 of the 4 strips - not sure if I'll put the last one somewhere.

The HDD came the day after the Hue+, and it proved to be the first real problem. Despite technically fitting, the SATA and power cables jutted out far enough to cause issue with the side panel, and I decided to say screw it and install it backwards. My PSU's SATA power cables are 3 connectors daisy chained on one cable, which meant I had to flip around the SSD as well (there's only 2 cables and one was in use by the optical drive). The HDD was actually fairly easy, but it made the ports for the SSD pretty hard to get to. Thanks to cable management holes on the other side of the case, it was doable.

Finally, all I needed was the GPU, and after agonizing days of waiting for announcements on aftermarket 480s, I ended up ordering a brand new Fury Nitro for $275, barely more than I was going to pay for a 480. So that's pretty incredible. But installing the GPU was where I really ran into problems...

First, because of the length of the card, I knew I'd need to take out a drive bay, which happened to be the one I had my drives in. I was smart and did that in advance - no problem, just swap out the trays and reroute the cables. It was actually quite easy and made me feel pretty good about myself. I also pulled out the VGA cables for my PSU and made sure they were good to go.

It came about 1pm on Friday, and I was leaving to go camping for the weekend about an hour later. I figured that was more than enough time to shove it in and install drivers, so I opened it up and got to work. This thing is seriously huge - it's a foot long and comes out to about a cubic foot. It was a lot harder than I expected to even get it in the case and lined up with the PCI slot due to the structure that holds the drive bays, and I had to unplug a few things to make it possible. I finally got it, hooked up the power cables I had ready and waiting, rewired everything else, and booted back up...and the motherboard didn't detect it. Its LED was on, but the UEFI was oblivious. I didn't have much time to troubleshoot and didn't have another card to test the slot, so I just had to leave it for the weekend.

When I came back Sunday night, I discovered that to put the card in the the third PCI slot (which was where it would need to go), I'd need to have both the drive cages out. So I did that and reinstalled the SSD and HDD in the two internal 5.25/3.5/2.5 bays, which was an incredible amount of work. Aside from the difficulty of working with that part of the case - meant as a last resort - the wires and things made it even harder to access. Eventually I realized that you actually need to break off a panel on the front side of each bay (which can later be screwed back on). Weird. But the truly insane part was plugging them back in. The SATA cables were long enough to be done easily, but the power cables weren't. I ended up having to set a camp lantern on top of the PSU and balance a flashlight in the front panel just to see what I was doing, and then put one hand on either side of the case to guide the connector into the port. I spent about 20 minutes on those two cables and worked up a nice sweat, and by then I was out of time. I put it back together, made sure it booted, and went to bed. The only thing that was really different was that I was able to use just one of the SATA power cables. Yay.

On Monday, my day off, my mom was in town and I didn't have a chance to do anything with it. Tuesday, I had about an hour before work, so I reinstalled the GPU into that third slot, started it up, and...nothing. The LED came on again, but it still wasn't detected. I discovered that the LED came on even without being connected to the PSU, but I didn't have time to do more before work. While at work I posted to /r/buildapc looking for help, and as I typed it up, I had a thought...but no, that couldn't possibly be it. It was the first thing that I'd ensured and it couldn't possibly have undone itself. It was too simple to be the answer to a problem such a dramatic issue. But it kept gnawing at me...

The moment I got home, I opened up my case and sure enough, one of the power cables had come unplugged from the PSU. I returned the card to the first slot, plugged everything up, and it worked. For the love of...

I'm not even mad. I'm just glad it works.

Images:
-Boxes, minus the cooler, HDD and GPU
-Mid-installation, right after I put the motherboard in the case
-Completed build with full view of cable hell
-Completed build powered up

Part Reviews

CPU

I ended up missing out on some good deals for the CPU, but still well worth it. I've overclocked it a bit just because I can and it's been perfectly fine.

CPU Cooler

Liquid cooling was honestly not my original goal but this thing does a pretty good job and the radiator acts like a couple extra case fans, which is neat. No complaints about performance, but the hoses got in the way of trying to do things while building.

Motherboard

I got a great deal on this mobo (the price I put in doesn't include the $30 rebate I'm waiting on) even though I still ended up spending more than I originally planned. But it has a plethora of handy features, is useful for overclocking, the UEFI is easy to use, and it has a handy debug feature. My only complaint is that the debug thing often leaves me wanting more information - why bother having 300 different error codes if you're only going to give me 15 unique diagnoses?

Memory

It's RAM. It runs at the advertised speed (once you set the XMP profiles). It looks nice. I think I paid an extra $3 to get it in black so it wouldn't stick out. Whatever.

Storage

Enough space to store the OS and some favorite games, but doesn't break the bank. I know it's not the fastest out there but coming from regular HDD, it's plenty fast for me. Well worth it.

Storage

Cheap. Works. Honestly haven't used it a ton so I won't give it a 5, but 2TB for $50 is as much as I can ask for.

Video Card

$275 is an incredible price for this and I'm glad I got this deal instead of the 480. I've honestly only played CSGO, Battlefield: BC2, and Dishonored so far, but it keeps all of them at my max framerate with the exception of occasional brief drops in BC2 (and freesync takes care of that). With less than 5 minutes in MSI Afterburner, I undervolted it and messed with fan speed settings, and it sat at or under 40C in Dishonored in about 2.5 hours of play.

Case

I chose this case based on a TomsHardware article, and despite some issues, I still really like it. I wanted something a little more on the rare side, rather than the millionth Fractal Design R4. It's also got a flashy window, unique (albeit sort of silly) styling, and decent cooling. However, I'm not sure I'd recommend it to someone planning to use a graphics card longer than 295mm because of the problems I had on top of the other cons.

If your card isn't that long, it's probably a good choice, but do keep in mind that it has breakaway slot covers. I bought a nice 10 pack of slot covers for $7 on Amazon (and you could certainly pay less) and just replaced all of them so I don't have to worry about those anymore. However, they can be pretty stubborn to remove, and I would recommend doing so before installing the motherboard.

Power Supply

Eventually upgraded to this after getting a deal (no memory of what I paid, though). Works great, although my TDP is the same as before...my only complaint is that the cables aren't pretty and braided like my EVGA PSU.

Optical Drive

Works fine, but no software. I knew that, I just didn't know how much of a pain it was to get a PC BR player working. I think I use Leawo.

Operating System

It's Windows. It works. I'm not sure if OEM was the right choice but it was cheaper.

Wireless Network Adapter

Works well. Ethernet in the house I rent doesn't work so wifi off the bat was a must. There was a $10 rebate on this one so I got ot instead of the $30 gigabyte one that's so well reviewed, and I haven't regretted it. I don't need bluetooth or anything so I'm happy.

Comments Sorted by:

CQC 11 Builds 4 points 16 months ago

That was a crazy deal on the Fury. Wish I would've gotten in on that deal. Good build!

jsoutherland89 4 Builds 1 point 16 months ago

No kidding!

noseonarug17 submitter 1 Build 1 point 16 months ago

I was pretty lucky to be awake for it, honestly - most days I wouldn't have been up until well after it sold out.

Iamoiman 2 points 15 months ago

Thank you so much for telling me a 550W PSU will work with the Fury. I also got it on sale (though for $350) on Amazon after waiting impatiently for the rx 480 to get in stock. Now I know I will not need a 650W PSU to replace my already purchased 550W (same PSU as you have too). Cheers!

Here is my build http://pcpartpicker.com/list/dDzrVY

noseonarug17 submitter 1 Build 1 point 15 months ago

Yep, glad to be of service. When did you buy that 550W GS? It seems to be a pretty high price for it.

Iamoiman 1 point 15 months ago

The price was incorrect on the listing. I got it for $50 on sale.

jsoutherland89 4 Builds 1 point 16 months ago

Awosome build!

[comment deleted by staff]
noseonarug17 submitter 1 Build 1 point 16 months ago

Probably not as rare as the Z11 Neo!