Description

First PC build, used primarily for gaming, streaming, and music production. I plan to live-stream some DJ mixes, original music production, as well as games.

On the build, I made just about every mistake possible. After 4 hours of unwrapping and assembling, I powered up for my first test and the Mobo was the only component receiving power. Day 2 consisted of ensuring each individual part was getting power, and troubleshooting connections to the mobo. At the end of day 2, all components were powered, but my final test resulted in no display (with post). Day 3 was spent fighting the no display problem, ultimately remedied by supplying BOTH power connectors to the GPU with power (I incorrectly assumed one of the power slots was for daisy-chaining to another PCIE slot). Day 4 consisted of OS install and updates, and now, I have a functional MONSTER PC!

Now I'm working through my setup and trying to ensure my configurations are lending them to my beefed up hardware. Any comments, tips, or feedback is appreciated!

Log in to rate comments or to post a comment.

Comments

  • 3 months ago
  • 2 points

It's a nice, clean build. I did a similar thing. Powered up and only the board came on. Realized I didn't plug in the 8 pin 12v power connector. I was hitting the DEL key to get in the bios, and realized I never plugged the mouse or keyboard in. Also my first build, am still waiting on the case. Some of the cable connections are harder to figure out than I thought.

  • 3 months ago
  • 2 points

Building my first computer and I have been a bit hesitant with the 5700xt. Was hearing it had some driver issues, and I am wondering if this is still an issue? If not I am going to get this gpu. It looks AMAZING.

  • 3 months ago
  • 1 point

I had zero driver issues out of the box. The only issue I had with the GPU was connecting BOTH 8 pin power connectors, using separate PCIE cables. Without power slots getting power, I couldn't get the display to show. Once I got it showing, there was no BIOS/Driver updates required to get it working. There was one driver update for it from the manufacturer site, but it was not required to function. Do IT! I love the RGB/logo on the GPU, and the performance is fantastic.

  • 3 months ago
  • 1 point

Sounds good. Thnx.