Description

I built this PC so I could edit videos, stream and game.

I have been building this PC over time and recently added the new motherboard, CPU memory, M.2 and CPU cooler and so far I'm loving it. CPU and motherboard temps are pretty good and if I remember to switch the GPU cooling to active instead of the always resetting default of passive the GPU temps are alright also.

Everything is set to default in the bios except I selected the memory and enabled XM 2.0 and the GPU is set to OC mode. I have done zero manual overclocking.

The CPU cooler has about 1mm between it and the memory, it doesn't foul but it is very close.

There isn't a very good selection of motherboards in Australia for M-ATX and the steel legend was the best I could find that comes with the correct bios for Ryzen 3000 out of the box and multiple PCIE slots. I was concerned with motherboard temps so i have every fan installed and the TF CPU cooler, but the heat sinks on the motherboard don't seem to get very hot so far.

I have now oveclocked the GPU and my results are as follows

https://www.3dmark.com/spy/8429052

Log in to rate comments or to post a comment.

Comments

  • 5 months ago
  • 3 points

Thats one expensive 1070ti

  • 2 months ago
  • 1 point

A 2060 Super is way cheaper.

  • 5 months ago
  • 1 point

Were you able to benchmark the stock cooler before you switch to Dark Rock TF? I was wondering how much difference Temps & Boost you get.

  • 5 months ago
  • 1 point

I posted the before and after with Cinebench results lower is stock cooler, higher with the TF cooler

  • 4 months ago
  • 1 point

How loud is it?

  • 1 month ago
  • 1 point

why did you get that motherboard ? did you had any issues with it?