Description

So this was my first build ever. I am not a computer wiz at all so i been doing all sort of research for the past 2 months. It was probably the funnest thing i have done in a long time can't wait for next build. Any tip / comments are appreciated. Oh, i did have one complication my Case leds do not work i been trying anything to get em working but i don't really have anything left to do. update I got them working properly now!

Part Reviews

CPU

Great CPU don't know to much but it is fast and very easy to overclock.

CPU Cooler

Keeps CPU Cool nicely. sub 20C for idle and haven't seen over 60C yet

Motherboard

Great budget MOBO but have to say Bios took me a little bit to figure out.

Video Card

Love this GPU! its a very solid card and one of the easiest to go with my color scheme. Haven't had a game this thing doesn't destroy.

Case

BEAUTIFUL CASE! only issue i have is LEDs don't work. After built i had some power issues so possible its not the cases fault but i do not know

Power Supply

its does what it needs to do. BUT when i first got build together i was haven't power issues. it was turning on and off repeatably. And trouble shooting it came done to power supply, ram or MOBO. Thankfully friend had an extra power supply. after about an hour of additional troubleshooting i found that the Molex connector to the Pref wire was doing something to both power supplies i dont know what it was but now got everthing except case LEDs working. so im fine with that

Comments

  • 47 months ago
  • 2 points

Clean looking build +1 Add some cable combs dressing them up a bit :D

  • 47 months ago
  • 1 point

I think its safe to say your favorite color is green

  • 47 months ago
  • 1 point

Haha nah it's orange but I like razer and already had razer mouse keyboard and headset so wanted to match

[comment deleted]
  • 47 months ago
  • 0 points

That's razar

[comment deleted]
  • 47 months ago
  • 1 point

Woosh

  • 47 months ago
  • 1 point

I'm getting a vibe that you like green... +1 for Illidan!

  • 47 months ago
  • 1 point

Haha just waiting to play that DH class

  • 47 months ago
  • 1 point

Holy **** this is sexy. +1 for damn sure.

  • 47 months ago
  • 1 point

Thank you

  • 47 months ago
  • 1 point

Which of the H440 LEDs aren't working? I had the same issue with the PSU razer logo but other than that everythings working. just make sure you plug the molex cable firmly(with force to make sure the 4 pin goes to the holes). I got mine from Mwave and the only thing that isn't working is the PSU razer logo doesn't light up so i just messaged them online and brought it in there shop and got a brand new case. Try RMAing it! especially when every green light of the case doesn't work.

  • 47 months ago
  • 1 point

I got them working. I was first having issues with power supply. The molex cable to it was shorting it out or something idk really. But I finally got the leds working yesterday and damn it looks nice :)

  • 47 months ago
  • 1 point

"plug the molex cable firmly(with force to make sure the 4 pin goes to the holes)." Glad it worked! for how long have you had this case with the LEDs not working? :D

  • 46 months ago
  • 1 point

Where did you get the cable sleeving?

  • 46 months ago
  • 1 point

I believe they are cablemod off of performancepc.com

[comment deleted]
  • 47 months ago
  • 1 point

The light is RGB

  • 47 months ago
  • 1 point

Well not quite but it would be a green and I understand your point. The windforce 980ti does however have a logo that if you want to you can change to green

  • 47 months ago
  • 1 point

After looking this isn't that model, only the g1 has it I think