add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Shutter problems on Star Wars Battlefront - Any ideas?

Robertbert

50 months ago

Hello there,

Recently upgraded my build to play Star Wars Battlefront (permalink: http://pcpartpicker.com/user/Robertbert/saved/Yycp99) w/ an R9 380 2 GB GPU and although I’m able to get fairly stable 40-60 FPS on “Medium” settings, Med or Low I’m getting some serious shutter on game load and some other random times, regardless of multiplayer or mission mode.

Any thoughts on what settings could be tweaked to reduce this? Is the VRAM the limiting factor here? Adding more system RAM helpful?

I am a novice to the OC world, but am willing to try with MSI’s OC Genie to see if that could help, but very wary of OC’ing the GPU.

Any input or thoughts is appreciated!

Comments

  • 49 months ago
  • 1 point

Make sure your not running other apps in the background. Keep graphics at medium to low. I was hitting 3gb on high settings but im getting 100fps.

[comment deleted]

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube