add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

bioshock.exe has stopped working

passive-aggressor

48 months ago

Recently, there was a 2K sale on Steam, and I was able to pick up all 3 Bioshock games for $10.49 USD. When I excitedly clicked on the first Bioshock, I got a loading screen for a second or two, then the Windows error message saying "bioshock.exe has stopped working". Google has pages of possible fixes for this. Problem is, no two fixes are exactly alike. For me, I had to first type in "-nosound" when I clicked on "set launch options" in Steam. This allowed the game to run, but gameplay had no sound (the cutscenes did, though). So, it's a sound issue. Google said the next step was to go to control panel > hardware and sound > manage audio devices > recording, then right-click on the list of devices, click show disabled devices, then enable stereo mix. Then I had to find bioshock.exe in my hard drive, right-click on it, go to properties, then run it in Windows Vista SP1 compatibility mode. Then, I had to go back to Steam, go back to "set launch options", delete "-nosound", and replace it with "-dx9". This worked for me, but may not be the answer for everyone. For example, people have said that all they did was enable stereo mix. Also, this kind of problem with this game has been around since Windows 7 came out, so don't expect a fix from 2K. What has worked for you guys?

Comments

  • 48 months ago
  • 1 point

Bioshock has been running without problems on both my Windows 7 laptop and my Windows 8.1 desktop. Not sure what causes it to crash on certain systems actually... Running in dx9 is a common fix for issues with that game, but you'll be missing some (albeit small) additions from dx11. But again, I'm not sure why it would work on some and doesn't on others. There are probably a couple of hardware (more specifically headphone/speaker) combinations that don't play nice with the DirectX implementation in Bioshock.

  • 48 months ago
  • 1 point

Use compatibility mode for windows vista or xp

  • 48 months ago
  • 1 point

One other interesting thing that I found was that for me, with the configuration I posted, the game will not work if I have Fraps going.

  • 47 months ago
  • 1 point

you got an old game, you need to install the software that was available back in that day. 2007

You need 32 bit Microsoft Visual C++ 2005 and 2008. Don't know if they have 64bit in 2005 :(

  • 47 months ago
  • 1 point

Don't know if they have 64bit in 2005 :(

they did, but since most people used a 32bit vista or XP, and XP 64bit was so buggy, most apps just used the 32bit libraries.

  • 47 months ago
  • 1 point

that game was out way before windows 7. I never could get it to work in 7.... id sometimes get up to 5 minutes in though.... Windows 8 and 8.1 on my laptop had no issues (except it was a dual core i5 with hd4000 graphics lol), and when I upgraded my desktop and laptop to 10, neither had an issue.... it just hates 7.

[comment deleted]

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube