add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

PSU question pls help

Talismenf22
  • 49 months ago

Okay I just received my psu. I will not say witch one it is because I don't want to be stoned to death. But any way if you plug up PSU outside a system as in not connected to anything how can you tell if it works or not? The fan is supposed to spin or something right? The one I have do not have any LEDs or power indicator light. So I don't know if it is working or not but I was also thinking that maybe it has to have power being drawn to spin the fan. Pls belp... Do I need to RMA or what ever its called

Comments

  • 49 months ago
  • 1 point

Okay I read something about jumping it with a paper clip I'm going to try that.

  • 49 months ago
  • 2 points

That will work. Bridge any black pin on the 24-pin connector with the single green one and the fan will spin if it is plugged in and switched on.

[comment deleted by staff]
  • 49 months ago
  • 1 point

Thermaltake TR 700w

  • 49 months ago
  • 2 points

Yes, the psu has to be plugged in to something, or nothing will spin. If you have your MOBO, look up how to test it with just the MOBO.

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube