PCPartPicker

  • Log In
  • Register

First Gaming PC No signal on monitor.

Forum Search

Guidelines

  • Be respectful to others
  • No spam
  • No NSFW content
  • No piracy or key resellers
  • No link shorteners
  • Offensive content will be removed

Topic

ThePCMasterBuilder 34 months ago

So I just finished building my first gaming PC. Everything turns on all the LED's and Fans. I plugged my HDMI cable to my graphics card to my monitor and it said no signal. Then I tried the VGA cable with a VGA adapter and it still displayed no signal. I also used the HDMI input on my motherboard and it still didn't work. I also plugged my keyboard to test it and the lights didn't light up. My specs: I7 6700k, MSI Krait Gaming Mothoerboard, Gtx 980ti, EVGA GQ 750w power supply, Hp 1080p monitor.

Comments Sorted by:

CircuitLord 1 point 34 months ago

Try putting the ram in different slots. Also, how can you be ThePCMasterBuilder if this is your first build? :D

ThePCMasterBuilder submitter 1 point 34 months ago

Cant switch them because of my heatsink.

CircuitLord 1 point 34 months ago

Well, if your not able to fix it otherwise, that may be your only choice.

ChrisZ 1 point 34 months ago

Try checking your motherboard manual, in case you missed anyhing

ThePCMasterBuilder submitter 1 point 34 months ago

I just went right through it and didn't miss anything.

JaysonCummins 1 point 34 months ago

When you start system, along with Power Light does HDD light glows? If yes, then I would suggest you the unplug all the cables and devices from system and drain the power from tower. (Disconnect everything from tower, press and hold power button for 30 seconds and after that connect only power, monitor, keyboard and mouse). Unplug the Video Card and connect the Video Cable to Motherboard. Restart the system and see if it works.

Regards, Jayson Cummins Tech Support Team