add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Did I purchase the wrong PSU?

Almightymints
  • 45 months ago

Just purchased an EVGA SUPERNOVA NEX650G and a MSI Z170 Krait Gaming motherboard. It seems the PSU only comes with a 4+4 cpu power connector but the motherboard requires an 8pin ATX 12v connector...

None of the cables that came with the PSU will fit (which sucks because multiple people recommended this PSU and mobo combination to me) and I'm stuck building my first PC.

Any solutions?

Comments

  • 45 months ago
  • 1 point

The PSU power connectors will work, you just have to put them together.

  • 45 months ago
  • 1 point

Definitely tried that, but the connectors don't even match what is on the motherboard...

  • 45 months ago
  • 1 point

Not to be rude, but you're doing something wrong in that case. I just did a build the past day or 2 with a split 4+4 pin cpu power into a 8 pin mobo socket.

  • 45 months ago
  • 1 point

No rudeness taken... I'm new to this so I probably am doing something wrong. Check my pictures to see what I'm talking about.

http://m.imgur.com/yfefXc5,pNi6Dmz

  • 45 months ago
  • 1 point

Yeah those pins in your hand go in that socket, put the pin side with the latches over the socket side with the tab, don't worry about the little miss match in exact pin shapes to socket shapes.

edit. oh I see your other reply, glad you figured it out :D

  • 45 months ago
  • 1 point

Could you take a picture of your problem them? Because, CPU connectors haven't changed much.

  • 45 months ago
  • 1 point

Did you try flipping them? Hold them together and press in.

  • 45 months ago
  • 1 point

He got it already.

[comment deleted]
  • 45 months ago
  • 1 point

Thanks for the help, I just wasn't pushing in hard enough. They both fit. I was nervous about bending the pins - just heard too many horror stories!

Thanks anyways, sorry to waste all your time!

[comment deleted]

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube