PCPartPicker

  • Log In
  • Register

(Installing Windows 7) A required CD/DVD drive device driver is missing.

Forum Search

Guidelines

  • Be respectful to others
  • No spam
  • No NSFW content
  • No piracy or key resellers
  • No link shorteners
  • Offensive content will be removed

Topic

qqwtf 28 months ago

SOLVED! I commented below on how I fixed it.


https://cdn.discordapp.com/attachments/213874261197193217/252639092456685568/20161127_161140.jpg

I get this error when installing Windows 7 Professional SP1 via Bootable USB 3.0 Flash drive. I am plugging the flash drive into a 2.0 port because I was recommended to do so, and I have talked with at least 5 different Microsoft support agents today in an attempt to solve this, with no luck. I've also tried booting from two different 16-GB USB 3.0 flash drives, using three different legitimate Windows 7 .iso's (Two of them were given to me by Microsoft support agents in case mine was at fault).

Everything in my build works except I cannot install the operating system - any ideas?

This is basically my build (because parts are always changing in it based on price, but otherwise it's the same): http://pcpartpicker.com/guide/wkmPxr/excellent-gaming-build

Comments Sorted by:

sKypP3r 2 Builds 1 point 28 months ago

Have you tried other usb port? as this usually helps

qqwtf submitter 1 point 28 months ago

Yes I have tried booting from a USB flashdrive in both 2.0 and 3.0 USB ports. There are at least 4 USB 3.0 ports and at least 2 USB 2.0 ports in my build, and none of them have worked.

DPRutledge 1 Build 1 point 28 months ago

How did you put Windows 7 on the USB? I ask because MSI motherboards require you to write the ISO to a USB using their Win7 Smart Tool, which you can find more information here:

https://service.msicomputer.com/msi_user/support/techfaqdetail.aspx?formid=3350

Stupid, I know, but this might work.

Stuart_Munto 2 Builds 1 point 28 months ago

Use a USB 2 thumb drive in a usb 2 slot. I had massive issues with this a few years back on multiple builds and it was all down to using a USB 3 thumb drive. Windows 7 installer seems to hate USB 3. The other problem you may face is that Skylake isn't officially support by Windows 7. Highly recommend you go for windows 10 to get the most out of your new hardware - windows 7 is showing its age now

qqwtf submitter 1 point 28 months ago

I have already tried several different USB flash drives in each one of the USB ports on the computer. I know they are operational because each one of them detects my mouse without a problem.

qqwtf submitter 1 point 28 months ago

I solved the issue! For anybody else having this issue, try what I did:

I downloaded the Windows 7* USB 3.0 Creator Utility by Intel and ran it. I selected my USB bootable flashdrive and the program did everything. Link here:

https://downloadcenter.intel.com/download/25476/Windows-7-USB-3-0-Creator-Utility

I guess I was just missing the USB 3.0 drivers. Good luck to anybody out there; this problem stumped me for a day now.

Stuart_Munto 2 Builds 1 point 27 months ago

Should have worked if you used a usb 2 thumb drive in a usb 2 slot. Either way glad you got it working!