add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

PSU makes crackling noise?

RtSquirrel
  • 33 months ago

My PSU makes a crackling sound when I put in the PSU plug into the actual PSU. Not sure if this is supposed to happen or not. Here is a video of what it sounds like: https://www.youtube.com/watch?v=d4Do6xwlbEE If it is faulty I need to return it quickly so any help is appreciated.

Comments

  • 33 months ago
  • 3 points

I say it is faulty. That sound often means a temporary short.

  • 33 months ago
  • 1 point

Is the switch on the PSU on or off?

  • 33 months ago
  • 1 point

The noise happens when the swich is both on and of. Aslong as the wall plug is on.

  • 33 months ago
  • -2 points

I love how great this forums page is. I got so much feedback and it helped so much! I HOPE YOU CAN SENCE MY SARCASM CAUSE U GUYS DID NOTHING A WASTE OF TIME.

  • 33 months ago
  • 1 point

Sometimes it just happens where there are a bunch of other posts in a subforum and yours gets buried in inactivity. Now that you have bumped this thread back up to the top, hopefully someone will be able to help you again.

And just so you know, you actually got 2 answers. I'm sure both of those people would have been happy to help you if you simply followed up with them. If you answer Orion's question, he or someone else may be able to help further.

  • 33 months ago
  • 1 point

Do you want people not to help you becasue this is how you get people not to help you. Being rude or disrespectful won't get you far.

You need to reply to them for them to know that posted otherwise unless they check back here they won't know that you left a comment.

  • 33 months ago
  • 1 point

Its that I would of expected a lot more from a huge website with loads of computer geniuses. Im not that angry anymore though. I went to another forums page and they helped me out in like 2 mins. Now my rig is working.

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube