add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Wondering if my psu is the culprit

Royalecheez
  • 29 months ago

Hey guys.

Having some strange goings on with my pc. Just built it, was running fine for a few days. Started to over clock some stuff. While over clocking the gpu I had a crash. Normal just thought I had reached the threshold. But now my pc is crashing all the time. The screen would turn off, keyboard and mouse would turn off, pc still looked on (all rgb leds and stuff were on fans going) and the dram oled was flashing in the mobo. So initially thought it was a ram problem. Memory test came back with no errors. Seems to only really crash while I’m playing battlefront for a little bit. Set bios and gpu back to defaults and it doesn’t crash. All tenpsmon cpu and gpu are totally normal. I’m at a loss. I was wondering if the overclocks just pushed the psu past it’s limit?

Any help would be greatly appreciated I’m tearing my hair out trying to figure out what is wrong.

Build is: Ryzen 7 1700 Asus ROG Strix x370 f mobo Asus ROG Strix rx 580 8gb OC 16gb g skill trident z rgb 3000 Corsair cx 650m psu

Comments

  • 29 months ago
  • 1 point

Try to set it back to stock and overclock will small steps.

  • 29 months ago
  • 1 point

It seems to not handle any over clocking

  • 29 months ago
  • 1 point

I was wondering if the overclocks just pushed the psu past it’s limit?

With that 650 watts psu, you can overclock everything till it explodes and you're still more than fine. You can even add another RX580 and still be fine...

http://hexus.net/tech/reviews/graphics/107647-sapphire-radeon-rx-580-nitro-crossfire/?page=12

You can try what Enrico suggested.. overclocking the gpu gradually.... Have you updated to latest bios?

  • 29 months ago
  • 1 point

Even with the gpu reset it was still crashing. With just the ram and the cpu over clocked. With everything to stock ram bios cpu etc. the computer acts like it wants to crash but I haven’t been able to get it too.

  • 29 months ago
  • 1 point

Does the motherboard have the latest bios installed?

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube