add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Ryzen 3 1200 GTX 1050ti performance questions

wcallstar

25 months ago

I recently built my first PC with a Ryzen 3 1200 Asrock ab350m pro4 and a Pny XLR8 GTX 1050ti you can find the rest of the parts here https://pcpartpicker.com/list/VPQFwV . The system has for the most part been running fine, the computer turned on the first time and Windows installed without any problems, the OS boots in around 10 seconds and I thought all was well. I built the system on Christmas and have since installed a few games to try out. The first games were Assassin’s creed 4 and Watch Dogs 1 since Uplay was giving them away for free. I had not done any research on how these games should have performed with the hardware I had selected and I just adjusted the settings according to the FPS Fraps was giving me. I can say that neither performed particularly well with AC4 staying around 45 FPS with settings on medium to low at 1080p and WD1 was running at 30 FPS with all settings on low at 1080p. I disregarded both and convinced myself that it was down to bad Ubisoft optimization. Then I downloaded Battlefield 1, a game I had done prior research on regarding performance, and the FPS was concerning. On the medium preset at 1080p I was barely staying above 30 FPS. I did not expect to max it out but from what I researched I at least expected a stable 60 FPS on medium. I read on Tom’s Hardware that a bios update could fix my problems, but I am really not keen on that idea out of fear for bricking the motherboard. Can anyone confirm if that would fix my problems. Any help is appreciated and sorry for the long post. EDIT: upon further inspection it appears my CPU is maxing out at 1.55 ghz, and I do not know why. Once again any help is appreciated

Comments

[comment deleted by staff]
  • 25 months ago
  • 1 point

My cpu is maxing out at 1.55 ghz with latest drivers and cpu temperature never going over 40 C got any thoughts?

[comment deleted by staff]
  • 25 months ago
  • 1 point

The issue was fixed with a bios update and everything is stable and running well.

[comment deleted by staff]
[comment deleted by staff]

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube