add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Wi-Fi Adapter not reaching optimal speed?

Acharne

25 months ago

So my wifi adapter is TL-WDN4800 802.11a/b/g/n Wi-Fi adapter. On my motherboard, I have 3 PCI-e x1 slots. The first one being blocked by my GPU. The 2nd one is legitimately like a cm below the GPU and the 3rd one, which is where my adapter is currently plugged in. Reading the motherboard manual, and I've discovered that the 3rd PCI x16 slot, first and third PCI-e x1 slot share the same bandwidth. Signal strength is not great, and usually goes from 3 to 2 bars.

On the other hand, I could see that my Wi-Fi adapter is currently set to the Wi-Fi standard of "802.11b" which is only 11mbps. My router can be set to both 802.11b and 802.11g, but on the settings it only has the b variant. Here are the full specifications of the router (note that this router is approximately 10 years old): https://bc.whirlpool.net.au/bc/hardware/?action=h_view&model_id=1187

Now I was wondering, what's causing my internet to reach around 14mbps (averaging around 1.8mb/s when downloading something)? I'm not sure whether the shared bandwidth PCI-e x1 (note that the other shared ones aren't being used whatsoever) or the wifi standard is the essential factor (which I believe is the problem). I just want a verification of the ongoing issue I have..

And if you need my build: https://au.pcpartpicker.com/list/p3jfKZ

Thanks.

Comments

  • 25 months ago
  • 1 point

At the sort of speeds discussed here, you can be sure that PCIe bandwidth is not a limiting factor. Besides, if you aren't using any of the other chipset linked expansion slots then there is no bandwidth sharing going on. It's only potentially an issue if you try to use the 3rd x16 (actually wired for x4) slot, and the x1 slots at the same time. A single PCIe 2.0 lane will support 500 MB/s (that's megabytes, not megabits).

According to the specs you linked to the router should support the 2.4 Ghz 802.11n standard. IIRC in it's basic form supports a link speed of up to 150 Mb/s (that's megabits per second). Don't expect actual transfers at anything like that rate, but it's a theoretical link speed in ideal conditions. But wireless standards are really confusing... In order to get the best speed, I think you would need to set the router to N mode only (rather than B/G/N mixed mode), encryption needs to be set to WPA2 AES, and you need to choose a non-overlapping channel (1, 6 or 11 I believe). If you have old devices that can't use WPA2 AES then you'll need to switch back to the mixed mode. But this lowers throughput for all devices.

BTW a useful app I've found (free) for simple testing of WiFi quality is Netspot. The free version is enough to allow you to verify whether any changes you make (for example to channel) is improving or weakening the signal.

  • 25 months ago
  • 1 point

There's a few complications I'd run into though. One being that I have no absolute of how to set my router to N mode, getting the encryption to be set to 'WPA2 AES' and choosing a non-overlapping channel. Generally speaking, I've never understood networking matters nor have I ever dealt with any. I just can't troubleshoot networking stuff when it breaks or is in most cases not performing at the optimal speeds.

  • 25 months ago
  • 1 point

Fair enough. Do you know how to access the routers configuration page? If it's using the factory default then its http://192.168.0.1 through your browser. Within the config menu's somewhere there should be the ability to change the router's WiFi settings.

I believe this is the manual - http://docs.netgear.com/cg3000/enu/202-10842-01/usermanual.pdf

Pages 12-16 are the most relevant.

  • 25 months ago
  • 1 point

I've used both '192.168.0.1' and '192.168.0.227', and both router IP addresses do not unfortunately work. I have no absolute clue on how to access the routers configuration page. I should also mention that the router is the 1staus model. The full name being 'CG3000-1STAUS'. Not sure if that's going to make a huge difference considering the link I posted only included the first portion of the name.

It seems as if the '192.168.0.227' router IP is correct. I tried troubleshooting the error and here are the results: "Your computer appears to be correctly configured, but this device or resource (192.168.0.227) is not responding".

  • 25 months ago
  • 1 point

It's probably an ISP customized version with their own firmware tweaks.

An alternative method they give is to use the web address http://www.routerlogin.net

  • 25 months ago
  • 1 point

Huh, it says the website is quite harmful in terms of stealing personal information. Although, I tried this on my mac which is currently connected to the same Wi-Fi network and get this message: "You are not connected to your Router’s WiFi network. To access routerlogin.net, your device must be connected to your Router’s WiFi network. Check your current connection and try again."

  • 25 months ago
  • 1 point

The most common ones that I have seen is http://192.168.1.1 or http://192.168.0.1 like you said, and these works on most networks. By default most networks have no username and the password set to 'admin' when you reach that page (It can vary by router, so consulting the manual doesn't hurt).

If you got your router from your isp it will most likely make you log into your account to access the administrator settings (ie. If you have a router from Verizon, it might ask you to log into your Verizon account).

Just like jonuk76 said above, disable mixed mode (you realistically won't have any device that needs it), and set it to fix WPA2-PSK (AES).

802.11ac is currrently the fastest- common- speed standard (not counting 802.11ad, as it's not common).

Your network does not support this, and in your case, 802.11n offeres the highest theoretical band with.That being said, your network is using the 2.4GHz frequency. While that's not generally a bad thing, and most networks still use it, it is being pushed out (slowly becoming less popular). This is happening because the 2.4GHz frequency is often interfered with by household applicances and other devices. The 5GHz frequency does not have as much interference. (That's the more simple version, but to amplify it: the 2.4GHz frequency supports 3 channels, this commonly can result in "overcrowding" of the channels, resulting in poor speeds. The 5GHz frequency supports 23 channels, meaning it is not as "interfered with" and can achieve higher speeds. So to simplify all that: 2.4GHz = slower but longer range, 5GHz= faster but shorter range.

Now, I felt the need to mention that on the point of interference. In that case I am referring more specifically to blocked signals. If your adapter was housed entirely within the metal PC case, then the signal would just bounce off the case instead of reaching the adapter. For this same reason, a good amount of wifi adapters protrude antennas from the case. With that in mind, I am assuming you have the antennas from your WiFi adapter protruding from your case, so turn them, your WiFi adapter looks* like it has 3 antennas, one should be pointed perpendicular to the floor/ceiling (should be vertical), the other should be parallel to the floor/ceiling (horizontal). And the third is can do whatever, maybe point it more diagnol, or if it bends that far point it at where the router would be through the wall.

Other than that, you don't really have too many options, a new router would helps, but that's not always practical. You could get a long Ethernet cables, which would be great for your PC, but can be inconvenient for you, particularly if it runs throughout your house. You could get closer to the router. You could get a wifi signal/rante extender. Or you could live with it, that's about it.

(This is presumming you have turned off mixed mode, and taken the other steps listed by jonuk and I. )

Good luck.

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube