PCPartPicker

  • Log In
  • Register

ASUS Z170 Pro Gaming MoBo troubles

Forum Search

Guidelines

  • Be respectful to others
  • No spam
  • No NSFW content
  • No piracy or key resellers
  • No link shorteners
  • Offensive content will be removed

Topic

Weeingwolf 6 months ago

I have the asus Pro Gaming MoBo and when I turn the power on it only last like 5 second then it just dies out. But the read lights still are on. I just can keep it on. Pls help

Comments Sorted by:

Gilroar 1 Build 1 point 6 months ago

Parts list?

Weeingwolf submitter 1 point 6 months ago

I’m not too good at this. I just went it buying random ****. Power Supply: CX750M Graphics: GTX Evga 1050ti CPU: i7

Gilroar 1 Build 1 point 6 months ago

Which I7?

Weeingwolf submitter 1 point 6 months ago

6700k

Gilroar 1 Build 1 point 6 months ago

Is the RAM seated properly?

And all the power cables attached CPU-8 pin and motherboard 24 pin?

Weeingwolf submitter 1 point 6 months ago

Yeah everything is plug in It turns on but just for a few seconds :-(

[comment deleted]
Bahamut5098 1 Build 1 point 6 months ago

Do you have a CPU Cooler? I plugged in your parts into a list and the following came up:

  • "Intel - Core i7-7700K 4.2GHz Quad-Core Processor does not include a stock CPU cooler. Adding a CPU Cooler to your part list is recommended."

  • "Some Intel Z170 chipset motherboards may need a BIOS update prior to using Kaby Lake-S CPUs. Upgrading the BIOS may require a different CPU that is supported by older BIOS revisions."

So, you may need to flash the bios to the latest.

ASUSTECHMKTJJ ASUS 10 Builds 1 point 6 months ago

Was it working previously or is the first time you have powered on the build. Please look to clarify?

If this is the first time ensure you can post outside of the chassis to ensure it is not a short/mounting issue.

Additionally check the QLED diagnostic LED and see where the board is failing to post ( there are 4 LEDs one for CPU, VGA, DRAM and BOOT ). You can reference your manual for location information.