add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

New to building need some help with A88XM-A

Prkeel
  • 76 months ago

Hi, my parts will be arriving tomorrow this is what ive got (just gonna show it all in case the extra info helps): CPU - AMD Athlon II x4 760k GPU- Sapphire Radeon R7 260x Mobo: A88XM-A FM2+/FM2 Memory: 4GB Crucial Ballistix Sport XT Case: Rosewill Line-M micro atx HDD- 1TB WD Caviar Blue Okay so my questions are....

1: Are all of these parts compatible with one another...

2: The case comes with 2 120mm Fans preinstalled i havent bought any other Fans/connectors etc.. will the mobo connect to the two fans without needing any extra parts? I think the rear fan has a 3 pin connector and the front fan has both a 3 pin and 4 pin connector.

3: How do I install an FM2 CPU (the x4 760k) on a mobo like this that is compatible with both FM2+ and FM2 sockets without breaking the pins...

Thanks for the help guys :)

Comments

  • 76 months ago
  • 1 point

1: yes all the parts are compatible 2: No, that mobo only has 1 cpu fan connector and 1 case fan connector. try this 3:The same way you would install a fm2+ cpu just line the gold triangle on the cpu up with the lower left hand corner on the socket.

  • 76 months ago
  • 1 point

Thanks a lot man, very helpful, will be building tomorrow :)... hopefully..

  • 76 months ago
  • 1 point

Your welcome, i hope everything works well with the build :). Will you be posting the finished product on here?

  • 76 months ago
  • 1 point

Hey so i began building my new pc today.. First of all I put everything together in the case (oops) all the wires and cables were plggued in in their spots... pushed power button no power. So i followed the tomshardware step by step guide.. nothing, i now have my parts on the mobo box with the GPU, CPU, and PSU all plugged into their specified locations. The green LED PWR light on the motherboard turns on when I flip the switch on the PSU but no power when i try to short the power pins on the mobo.. (which i have also tried using the case headers with the power button itself) No fans turn on.. nothing pops up on my screen (which is connected through an HDMI on the GPU) I am a noob to this so I could very well be doing something wrong, but from the videos and guides ive watched and read everything should be wrking.. Any ideas? Any help would be greatly apreciated as i have practically sat on my porch waiting for this to arrive for days and now I cant get it to work :(. Thanks Pcpartpicker community :)

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube