add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Cryorig H7 not lining up! Desperate help! Please!

jbustos
  • 23 months ago

Hey guys so I'm here building my awesome PC and for some reason I can't get the xbar on the cryorig to line up with the backplate/mobo I'll upload some pics so u see what I mean, I took the backplate off the mobo because I couldn't get it to line up on the mobo and wanted to see why...I tried opening and closing the xbar but there's was not much difference.

https://drive.google.com/open?id=1Bue_pJZLAX3jX811bDiEkUT2xB361otT

Comments

  • 23 months ago
  • 1 point

What motherboard do you have?

Have you read the manual?

if you have an AM4 motherboard, you can apply for an upgrade kit for that socket type.

  • 23 months ago
  • 1 point

z370 already chamged the cooler which wasnt working thanks for the reply

  • 23 months ago
  • 1 point

yes I did the xbar was stuck to the amd position and wouldnt go to intel position, I had to return it and go get a different one. Finished my built already thanks for the reply though! ;)

  • 23 months ago
  • 1 point

I'm glad you're sorted. :)

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube