add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

How To Change Display Settings?

Owen_Electric

22 months ago

I recently built my PC, downloaded windows 10, and want to make sure I am in 144hz (it looks like 60 at the moment). No matter how hard I look, I cannot find the display settings with this option. Help?

Build - https://pcpartpicker.com/user/Owen_Electric/saved/8Ktd6h

Monitor - https://www.newegg.com/Product/Product.aspx?Item=N82E16824106004

Comments

  • 22 months ago
  • 1 point

Right click the desktop and select NVIDIA Control Panel. Go to "Change Resolution" and it will show what resolution and refresh rate is selected.

  • 22 months ago
  • 1 point

I don't see an option for that, I had a laptop in the past with that option, but it don't see it in my new PC. I also cannot find the Intel display settings.

  • 22 months ago
  • 1 point

Could this be from an outdated graphics driver? I have a card that hasn't been used in two years.

  • 22 months ago
  • 1 point

That list shows you are using a GTX 960. You need to install the driver to get the NVIDIA Control Panel. If the card isn't installed then you are using Intel integrated graphics. You could also try right clicking the desktop and select "Display Settings". Then go down and select "display adapter properties". Then click "monitor" and a refresh rate option will be there to see what it is and change it. I don't think Intel integrated graphics allows choosing 144Hz. I could only select that refresh rate with a dedicated graphics card.

http://www.nvidia.com/Download/index.aspx

You need to use a display cable that supports 144Hz like dual-link DVI or DisplayPort. The monitor should have came with the cable you need. Don't use HDMI. The DVI or DisplayPort cable should be plugged into the GTX 960.

  • 22 months ago
  • 1 point

I am installing drivers now, and I had been using an HDMI. Thanks for the help.

  • 22 months ago
  • 1 point

You need to use DisplayPort to use g-sync

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube