add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Corsair Scimitar Mouse has to be reconnected on every boot.

Esamenoi
  • 22 months ago

Pretty much title but here's a bit more detail.

I have a factory refurbished Scimitar that I go a few months ago. It's been really good and was a substantial upgrade from my Redragon Perdition.

In the few weeks I regularly have to unplug and replug in the USB for the mouse for it to be recognised. Otherwise the mouse isn't lit up at all and doesn't work.

Anyone know why this could be? Or should I just reach out to Corsair for replacement?

Cheers!

Comments

  • 22 months ago
  • 1 point

This maybe a silly question, but does it help if you move the mouse around right after hitting the power button to boot your PC? The reason I ask is because I have a Corsair 65M Pro Mouse that sort of does the same thing. However as long as I move it or click one of the buttons during during the boot it is recognized.

  • 22 months ago
  • 1 point

huh, curious. Ok I shall give this a try this evening when I get home from work!

Apparently this does seem to happen to multiple people though.

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube