add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

M.2 SSD not appearing in Bios

PartPickerBoi

21 months ago

I have a WD green M.2 2280 Solid state drive installed in the rear M.2 slot on my Asus strix Z370-I gaming motherboard but when I boot into the Bios and try to install windows it isn’t listed as somewhere to install windows? Should it be installed in the front m.2 slot instead?

Comments

  • 21 months ago
  • 1 point

I know that you're often able to disable/enable M.2 slots. I would check the BIOS for anything like that. Otherwise, definitely give the front slot a shot and see if that works. My other recommendation would be to download the latest drivers for the motherboard.

  • 21 months ago
  • 1 point

Thank you I’ll have a look. Will post updates shortly.

  • 21 months ago
  • 1 point

Sounds good.

  • 21 months ago
  • 1 point

Moved it to the other M.2 slot and it is now working like a charm, both M.2 slots are enabled for the future.

  • 21 months ago
  • 1 point

Awesome!

  • 21 months ago
  • 1 point

I would try the one at the bottom of the board under the heatsink.

[comment deleted]

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube