add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Frame rate issues

Zues2k
  • 21 months ago

I just replaced my CPU with the one listed in the build here https://pcpartpicker.com/list/fYsDq4 and everything went smooth. All drivers updated and all but since then I've been getting frame rate drops pretty often in Destiny 2 and other games, such as PUBG. Before the cpu change, could play Destiny 2 on high settings with no issues but now it's giving this issue, as well as the other games.

I ran a stress test right after installing the cpu and that all went perfectly fine. I change the setting to low/medium on the games and still have the issue. Any ideas?

Comments

  • 21 months ago
  • 1 point

Do you really have two different types of memory installed in your machine?

  • 21 months ago
  • 1 point

Yes, they are both 8GB, same brand, same speed, DDR3. Could that be causing an issue like this?

  • 21 months ago
  • 1 point

What CPU did you have before? Was the CPU the only thing you changed?

  • 21 months ago
  • 1 point

It was the FX-6300. The power supply and gpu were recently replaced but it was a few weeks before the cpu was.

  • 21 months ago
  • 1 point

What stress test did you run, and did you check the CPU temperatures?

You did install new thermal paste, correct?

  • 21 months ago
  • 1 point

I did the test with Aida 64, monitored the temps the entire time, steady and maintained the entire time where it should be.

Yes new thermal paste was added after cleaning off all the old paste from the other cpu.

  • 21 months ago
  • 1 point

Did you check the temperatures of your motherboard, perhaps the VRMs are getting a little to hot. That is all I can think of.

  • 21 months ago
  • 1 point

The MB temps barely move more than a degree or two during the stress test

  • 21 months ago
  • 1 point

Ok so talked to a buddy of mine and looked into it, it seems that the FX 8350 throttles at 61 degrees. Maybe wondering if that's my issue with this frame drop issue.

  • 21 months ago
  • 1 point

Alrighty so I think I've narrowed down my issue. Playing PUBG today and was monitoring my CPU/GPU usage and temps. Every minute or so the usage would drop on the GPU to anywhere from 20-40% usage. Temps are all in the proper ranges. Seems to be pointing at the motherboard is getting too hot. Using HWmonitor the MB temps were peaking around 62 to 65 degrees Celsius. Any tips to fix this? All fans are running but the case Im using is rather limited on the front intake.

[comment deleted by staff]
  • 21 months ago
  • 1 point

That would require a completely new MB.

[comment deleted by staff]

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube