PCPartPicker

  • Log In
  • Register

Pretty sure this is a motherboard problem, but not 100%

Forum Search

Guidelines

  • Be respectful to others
  • No spam
  • No NSFW content
  • No piracy or key resellers
  • No link shorteners
  • Offensive content will be removed

Topic

tragiktimes101 10 months ago

So, I have been having a weird occurrence with my wife's build. Here is the system:

PCPartPicker part list / Price breakdown by merchant

Type Item Price
CPU AMD - Ryzen 5 1600 3.2GHz 6-Core Processor Purchased For $130.00
CPU Cooler Corsair - H60 54.0 CFM Liquid CPU Cooler Purchased For $15.00
Motherboard MSI - B350M BAZOOKA Micro ATX AM4 Motherboard Purchased For $35.00
Memory Crucial - 8GB (2 x 4GB) DDR4-2400 Memory Purchased For $50.00
Storage ADATA - XPG SX6000 128GB M.2-2280 Solid State Drive Purchased For $25.00
Storage Western Digital - Caviar Blue 1TB 3.5" 7200RPM Internal Hard Drive Purchased For $10.00
Video Card PowerColor - Radeon RX 560 - 1024 2GB Red Dragon OC V3 Video Card Purchased For $85.00
Case Cooler Master - MasterBox Q300P MicroATX Mini Tower Case Purchased For $55.00
Power Supply Corsair - Builder 500W 80+ Bronze Certified ATX Power Supply Purchased For $15.00
Prices include shipping, taxes, rebates, and discounts
Total $420.00
Generated by PCPartPicker 2018-05-28 15:04 EDT-0400

The problem that I have been having is in regard to the boot device. It has worked fine for a few months, but has recently been shutting down randomly. After the shut down, it either goes the BIOS screen (sometimes) or it attempts to boot fine, but reads that it can't find boot media. I went back into the BIOS and saw that in the boot order the SSD (m.2) is not being recognized as a UEFI drive. Instead, there it is just labeled as a non UEFI drive. It has some obscure name that has NVMe in it. The boot drive that is listed as UEFI boot drive isn't named, and can't be booted into. It's like it can't figure out the name of the drive.

So, I decided to clear my CMOS and to unplug my HDD to see if that solved anything. Well, it does, temporarily. When I boot into the BIOS after the CMOS clearing, it states that the first drive in the boot priority is the ADATA XPG XS6000. So, the name is different now, weird. And, on top of that, it's actually recognized as a UEFI boot device with a name (Windows boot manager: ADATA XPG XS6000).

So, it's fixed, kind of. It occasionally shuts off and goes through this ordeal again. And, it doesn't allow me to plug my HDD in without causing the issue. Which is weird, because the HDD was used alongside it for months with no problems up until now.

I suspect I may need a BIOS update. I have reset settings multiple times with no benefit, so the BIOS update is all I can think of at the moment.

Any help would be appreciated!

Comments Sorted by:

treloar 1 Build 1 point 10 months ago

Can you set any kind of delay on the HDD so it goes to the NVMe first and boots it?

tragiktimes101 submitter 1 Build 1 point 10 months ago

Unfortunately, even with the HDD removed the problem arises. It's as though the motherboard isn't able to recognize my SSD about half the time. A CMOS clearing fixes it everytime, temporarily. But, the problem comes back. I updated my SSD drivers as well as a few other drivers and so far the problem hasn't returned. But, I've read very similar accounts on other MSI boards, so I think it's a mobo issue. So, it's hard to determine if the problem is solved or not. If in a few days it happens again, I'll know it's not solved. But, if it doesn't do it again I plan on adding my HDD back to see if that causes an issue or not.

thunder-93 1 point 10 months ago

I'd recommend a mobo BIOS update, if you're comfortable with doing it. Most current bios is 7A38v1E released this month, available at: http://download.msi.com/bos_exe/mb/7A38v1E.zip

Try that first, to see if the bios update fixes the issue. Note that on some mobos, even if you update to the same bios version, it sometimes "knocks something loose" on the mobo.

Also, have you uninstalled and reinstalled the M.2 NVMe drive for good measure?

tragiktimes101 submitter 1 Build 1 point 10 months ago

I haven't updated the BIOS yet but downloaded the newest one. One problem is I can't find my flash drive at the moment, lol. But, I have uninstalled and reinstalled the M.2. I'm not 100% sure, but since I updated the drivers it hasn't had the problem again since. But, I have yet to reinstall the HDD. So, it's hard to say if that will reintroduce the issue.