PCPartPicker

  • Log In
  • Register

New ram not running at full speed?

Forum Search

Guidelines

  • Be respectful to others
  • No spam
  • No NSFW content
  • No piracy or key resellers
  • No link shorteners
  • Offensive content will be removed

Topic

Frostbite11 6 months ago

I’ve just finished building my pc and when I went into the bios I noticed my ram which should be running at 3000mhz and cas 15 was actually running at 2133. I’m not sure how to make it so I can run my ram at full speed. I haven’t turned on/made a xmp profile yet as I’m not too sure what it does? So how do I get my ram to perform at the listed speed? Thanks

Comments Sorted by:

Gilroar 1 Build 2 points 6 months ago

So how do I get my ram to perform at the listed speed?

You do this.

I haven’t turned on/made a xmp profile yet as I’m not too sure what it does?

XMP is a preset overclocking profile onboard the RAM DIMM.

Unless you enable it, a similar profile, or manually overclock the RAM it will run at DDR4 standard speed which is 2133mhz.

Frostbite11 submitter 1 Build 1 point 6 months ago

Ok thanks

lodie187u 1 Build 1 point 6 months ago

Go into your bios and enable xmp profile.

mark5916 1 point 6 months ago

On you main BIOS screen, switch to Advance mode (F7), go to Ai Tweaker tab and...

Ai Overclock Tuner: XMP

XMP: Select a profile that matches your rams highest speed.

Save & Exit. (F10)

Frostbite11 submitter 1 Build 1 point 6 months ago

Thanks

mark5916 1 point 6 months ago

You're welcome. ;)

Tell us if you did it!

Frostbite11 submitter 1 Build 1 point 6 months ago

Yes I set the xmp profile. Opened up the bios and did it in seconds. Once again thanks for your help

mark5916 1 point 6 months ago

No problem.

Enjoy your new Computer. ;)

Velcade 3 Builds 1 point 6 months ago

you sure love to wink