add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Very low fps with 1050ti?

AtaOzd

18 months ago

I recently got a pc with a Ryzen 5 1500x and PH-GTX1050TI-4G. I was expecting high results due to the videos of testing I watched online but it wasnt correct. I get 99% usage and 20-30 FPS at suggested settings. I believe there is a problem with the GPU, any tips?

fyi: I have 16 GB 2400 RAM, a 1 TB HDD and 120 GB Adata SSD

edit also an Asus - PRIME A320M-K

Comments

  • 18 months ago
  • 1 point

What games are you getting those frame rates in?

Are your GeForce drivers up to date?

  • 18 months ago
  • 1 point

Rainbow Six: Siege, and they're up to date ( At least the GeForce Experience ones)

  • 18 months ago
  • 1 point

Doing a quick search and it looks like frame rate problems with that game are pretty common. I found this thread, and it seems that the game like to set the rendering scale to above 1080p after updates. I would check your game settings and see if that helps.

https://www.reddit.com/r/Rainbow6/comments/8pi378/fpsdrop_since_para_bellum/

You should also try some other games and see if they have issues.

  • 18 months ago
  • 2 points

Well that worked for R6!

  • 18 months ago
  • 1 point

also would you recommend overclocking my gpu?

  • 18 months ago
  • 1 point

You can, may get you a few more FPS in your games. Just have to keep an eye on temps.

  • 18 months ago
  • 1 point

I played around with the setting to find out I was rendering the game at 2K! I turned it down so It plays normally now, Thannk you <3

  • 18 months ago
  • 1 point

This, and do you have the drivers installed period? For the chipset, video card, and etc? Not having this cripples performance if the game runs at all

  • 18 months ago
  • 1 point

I'll check all drivers

  • 18 months ago
  • 1 point

I used the CD ones

  • 18 months ago
  • 1 point

I'm downloading the chipset atm

  • 18 months ago
  • 1 point

I mean I just plugged in the PC and put the CD in, maybe the drivers are outdated? I’m downloading them again, this time from the website

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube