add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Retroarch not working with Ubuntu

sparky@intel
  • 21 months ago

Hi, So I'm trying to install RetroArch onto Ubuntu 18.04 LTS, using this guide: https://docs.libretro.com/compilation/ubuntu/

When I enter ./configure into the terminal, I get this output:

./configure: 5: ./configure: cannot create config.log: Permission denied Checking operating system ... Linux (Ubuntu 18.04.1 LTS 18.04) ./configure: 8: qb/qb.comp.sh: cannot create .tmp.c: Permission denied Checking for suitable working C compiler ... not found Error: Cannot proceed without a working C compiler.

I understand that there is no C compiler- does anyone know how to fix this problem?

Comments

  • 21 months ago
  • 1 point

Go into the software manager, search for gcc, and install it. I don't have Ubuntu in front of me or I'd try to be more specific.

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube