add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Monitor not displaying and red cpu light is on

eboomer

16 months ago

https://pcpartpicker.com/list/zLWnNQ

Hi,

My build is posted up top, I just built my first pc and the monitor wont display, also has the cpu red light on the bottom right corner where the vram/cpu/boot lights are. im wondering if this could be a bad mobo? or possibly a bios update is needed since its the ryzen?

thanks for any help

Comments

  • 16 months ago
  • 1 point

My initial thought is to make sure everything is seated correctly. By everything I mean not only components, but also power adapters. It is most likely a CPU power that you forgot/ didn't push all the way in.

http://www.tomshardware.com/faq/id-1893016/post-system-boot-video-output-troubleshooting-checklist.html

Try following this guide and let me know if you have any more questions!

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube