add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

New PC build dont work

FoxyFlash16

15 months ago

Hi i build pc for my friend. When im trying to turn it on, its working coolers are spinng there is no speaker sounds and no screen.

Parts:

GPU: Zotac GT 710 2gb vram

CPU: intel celeron G1820 2.7ghz

MOBO: H81 LGA 1150 DDR3

PSU: 300 W

I have 2 ram sticks:

1 G.skill: 8gb ddr3 1066mhz

2 Ddr3 4 gb 1600mhz

Comments

  • 15 months ago
  • 1 point

Try booting with just one stick of ram. Try both sticks but one at a time.

  • 15 months ago
  • 1 point

I tried it many times. But thanks

  • 15 months ago
  • 1 point

remove the GPU

  • 15 months ago
  • 1 point

Check compatibility of your ram for the MB. If not on the list get ram that is on the list. If its on the list install GPU in a working system and see if it works. Swap monitor cable or/and ports if available.

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube