add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Ryzen 5 2600X Causing Stuttering?

XsBigBoi

14 months ago

i recently moved my system over to ryzen (did a clean instal of windows) and there is stuttering no matter what i'm doing especially media playback. I've noticed that when watching youtube or netflix it stutters and the CPU Utilization on Task manager goes up to about 50% for a second or so. I have tried reinstalling drivers and reseting bios. The only thing i can think of is my RAM as i have heard ryzen has problems with some RAM.

My Specs Processor: Ryzen 5 2600X GPU: 1080ti RAM: 2x8GB Corsair vengeance LPX HDD: WD Black 1TB (Spanned volume) SSD: Samsung 850 evo 250gb PSU: Evga 750 G3 Soundcard: Strix Soar WiFi Adapter: Asus PCE-AC68

Comments

  • 14 months ago
  • 1 point

Sounds more like software than hardware to me. Make sure you don't have some kind of malware or background app that's waking up occasionally and doing stuff.

  • 14 months ago
  • 1 point

I did 2 clean installs of windows and the same issue occured twice

  • 14 months ago
  • 1 point

It's certainly not a generic Ryzen problem, and I can't think how RAM would be involved. Maybe the sound card driver? Maybe a windows patch version? without knowing what is running up the CPU, it's hard to say.

  • 14 months ago
  • 1 point

I think it is windows antimalware service executable

  • 14 months ago
  • 1 point

Real time protection can do that. Try turning the real time protection off and see if the problem continues. Lots of antivirus programs especially those with real time protection can be fairly CPU heavy.

  • 14 months ago
  • 1 point

Turns out it was my CPU Playing up, tested with an A8-9600 and all the stuttering was gone

  • 14 months ago
  • 1 point

Glad you found the issue.

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube