PCPartPicker

  • Log In
  • Register

New Build PC - No signal to monitor / TV

Forum Search

Guidelines

  • Be respectful to others
  • No spam
  • No NSFW content
  • No piracy or key resellers
  • No link shorteners
  • Offensive content will be removed

Topic

carlyp87 8 days ago

Hello,

I've just completed my first PC build using the parts below, it powered up straight away but I'm not getting a signal when I connect it to a PC monitor or when I connect it to my TV with a HDMI cable.

CPU - AMD - Ryzen 7 1700 3 GHz 8-Core Processor Motherboard - MSI - B350 PC MATE ATX AM4 Memory - Kingston - HyperX Fury Black 8 GB (2 x 4 GB) DDR4-2133 Storage - Samsung - 860 Evo 500 GB 2.5" Solid State Drive Toshiba - P300 1 TB 3.5" 7200RPM Internal Hard Drive Case - Corsair - Carbide Series 275R (White w/Tempered Glass) ATX Mid Tower Case Power Supply - SeaSonic - 520 W 80+ Bronze Certified Fully-Modular ATX Power Supply

I don't intend to do any gaming so I didn't get a graphics card, but now wondering if I should have? I got a lot of the parts in the Black Friday sale for cheaper, so I did opt for the Ryzen 7 CPU, but probably overkill for what i'll use it for.

Have I missed something obvious or can anyone suggest what I may have done wrong please?

Thank you.

Comments Sorted by:

worstcaster 1 Build 1 point 8 days ago

Your CPU does not have integrated graphics, so without a video card you will have no display. You either need a card or to switch the CPU to one with integrated graphics. Here is an example: https://pcpartpicker.com/product/FGPKHx/amd-ryzen-5-2400g-36ghz-quad-core-processor-yd2400c5fbbox

carlyp87 submitter 2 points 8 days ago

Can't believe I missed that! I was originally getting the Ryzen 5 and then found the Ryzen 7 on offer so opted for that instead.

Thank you, total amateur and lesson learned!

Appreciate your help.

LeviAMD 1 Build 1 point 8 days ago

worstcaster is right. Also, did you update the BIOS? Sometime's you'll need to do that with b350 mobos