add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

ASRock B450M-HDV w/ Ryzen 3 2200G won't power on

parmour42
  • 14 months ago

I'm building my first computer and i've got a ASRock B450M-HDV motherboard and the Ryzen 3 2200G CPU. I've connected and reconnected everything multiple times. When I power it on, all the fans run, the disk drive spins but yet nothing happens on the screen. I've attempted to clear the CMOS and still shows on the screen. And yes, the screen is connected correctly. Any help would be greatly appreciated. Thanks

Comments

  • 14 months ago
  • 1 point

Hi,

Quick question: are you running any kind of adapter between the motherboard & the monitor?

  • 14 months ago
  • 1 point

I'm not, the monitor is connected straight to the MB via the provided VGA cable.

[comment deleted]
  • 14 months ago
  • 1 point

Check that all power supply cables are in the right place and properly plugged in (I know you've done this, but ...)

Remove and re-seat the RAM. Pull all but a single ram stick and try it in different RAM slots. If all else fails, take out the CPU and look for a bent pin, make sure it's properly oriented in the socket.

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube