add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

o and x text on screen, monitors not working

AstRgnlMngrDwightSchrute
  • 12 months ago

I came over to my computer to find what looks like space invaders on my screen, i restarted my pc, and now only one of my monitors is working and the resolution is completely messed up. someone please help

Comments

  • 12 months ago
  • 2 points

Time to reach out to the GPU vendor and RMA it. Sounds exactly like hardware related problems that have come up with some RTX 20 series GPUs (that looks like space invaders, GamersNexus has a good video describing the issue). If your GPU is new enough, would be easiest to RMA through where you bought it (like NewEgg or Amazon)—I’d check there first. And if that doesn’t work, then contact MSI directly to request warranty/RMA.

  • 12 months ago
  • 1 point

From what you have described, it is probably the GPU. Do you have a picture?

(It could also be the monitor cable, but that is less likely)

  • 12 months ago
  • 1 point

No picture. It will only let me set the resolution to 1024x768. I just built this pc a month ago. :(

  • 12 months ago
  • 1 point

Is the cable plugged in to the video card or the motherboard? Also, is it HDMI or VGA? If it is VGA, it is capped at 1600x1200, so it wouldn't be a very high resolution.

A part list could help too.

  • 12 months ago
  • 1 point

https://pcpartpicker.com/list/7Z2czY

I haven't had a single problem until I left my computer for like 30 mins and came back to it frozen with that weird text. My monitor is 1440p 144hz DP.

  • 12 months ago
  • 1 point

Can you post a screenshot of CPU-Z open to the "Graphics" tab?

  • 12 months ago
  • 1 point

I'm looking in Cam and its not even showing my GPU now

  • 12 months ago
  • 1 point

Here's the link to the video I mentioned in previous post: https://www.youtube.com/watch?v=JIRfPlC15uc

(start at time 2:04 ... and picture of the "space invaders" artifacts starting at 2:09)

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube