add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Upgrade or not getting the performance I should?

cheftony

11 months ago

So I built this 4 ish years ago I always felt like something is wrong, like I'm not getting what I should out of the hardware inside. I play pretty low end games as far as graphics go and play on medium to low settings to maximize performance. I have been thinking about doing another build either upgrading/side grading but I want to figure out if I am bottle necking something on this rig. Basically any game I put on the normal hard drive is unplayable 25-45 second load screens often with the program not responding I also seem to Max out the ram which makes no sense 16g. This does not occur when playing games that are installed on the SSD. But I still get strange screen tearing have to use (sync) horrible for drops. In the past week these things have gotten worse even slow load speeds on web sites. My speed test come back 250 down 45 up. I have ran a few PC performance type things in the past but I'm just not very tech savvy.

https://pcpartpicker.com/user/cheftony/saved/

TDLR: what can do to check if my system is running as it should?

I need a second desktop for wife/kids budget $500-$700 what could I do to maximize a single rig with the current parts/budget and make a second low end desktop (steam games/youtube/photo storage)

Comments

  • 11 months ago
  • 2 points

Download and run a standalone memory tester such as memtest86. Run a few hours of a stress test, prime95 or realbench. If those don't show any issues, it could be something software related; could you do a clean reinstallation of Windows? It's also possible that you have multiple issues, possibly a bad hard drive along with some sort of software or malware issue.

I see nothing in the parts list that is suspect. The CPU is still pretty good for all but very heavily multi-threaded games, and the GPU isn't too far from today's RX 580. The rig should run many games very well.

Added: if you don't see a memory or CPU problem, one thing you might try is replacing the hard drive SATA data cable between the hard drive and motherboard. These occasionally fail causing weird symptoms, although outright "no drive" is by far the most common.

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube