add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

graphics card issues

mad_cow22
  • 10 months ago

I recently completed a slightly modified version of the 'entry level gaming build' https://pcpartpicker.com/guide/GFLrxr/entry-level-amd-gaming-build

Ryzen 2200G Gigabyte Radeon rx570 amd b450 ripjaw 4 series 8gb 450w power installed win 10

My issue is the graphics. This is my first build although I am upgrading from a 7 year old comp so the basics like the monitor being faulty isn't likely. I turned comp on first start and everything turned on except fans but that was my mistake. Entered BIOS and everything seemed to check out although I did not see my graphics card info anywhere only the chip. Graphics card was not present on Device Manager until after running b450 driver disk and gigabyte disc. After that the Ryzen and rx570 show up in device settings, up to date drivers, and functioning properly.

The issue is twofold... 1. Resolution settings are greyed out in 'Display Settings' and icons are partially off screen. 2. Graphics are not right. I'm not seeing any major issues, but text is jagged, colors seem off and video graphics are not crisp. Compared to my 7 year old comp, the graphics are from the 90's.

I uninstalled through device manager and restarted / re installed. Updated graphics card driver today. What am I missing?

Comments

  • 10 months ago
  • 1 point

Is your cable connected to the video ports on the back of the motherboard or the back of the graphics card?

  • 10 months ago
  • 1 point

I will dig into it soon and check... Please read my response to Potatogamer and see if that makes sense. I will double check ports. Thanks!

  • 10 months ago
  • 1 point

Hahahahha! I'm an idiot. You guys nailed it. I didn't actually switch the cables yet, but I just looked and there is a neat little rubber cap over the graphics card port. I will confirm results, but you guys solved it sight unseen. Thanks!

  • 10 months ago
  • 1 point

make sure the cable thats connected to the moniter if leading to the graphics card not the motherboard. also just incase make sure you plugged in the power cord to the gpu

  • 10 months ago
  • 1 point

Hey thanks for the advice. I will check ASAP. Just as an update, I am watching some videos and video doesn't seem bad, but text in videos, text on my desktop windows, and the text I am typing right now is pixelated a bit. All the text I am seeing is a little jagged. Hope that makes sense.

  • 10 months ago
  • 1 point

Thanks Potatogamer, you nailed it. I just looked at the back and immediately see that the monitor is plugged into the board and not the card. Thank you very much for getting back to me on this one. I will report results, but I'm pretty sure you solved it.

  • 10 months ago
  • 1 point

Okay, so I switched the HDMI plug, but unfortunately I am not seeing a difference... Guess I spoke too soon. After switching the plug, the GPU no longer appears under 'Display Adapters' just the graphics card so good there. I had a PCI driver that was not found after the switch so I ran the B450 setup disc and that was solved. I still have the icons on the desktop mostly offscreen including the taskbar along the bottom. I am on the recommended screen resolution of 1920x1080. Lowering this leaves me with black borders. -SOLVED I changed aspect ratio of monitor to 'Fit' instead of '16:9' which put the desktop icons on screen.

Text is still pixelated / jagged and not smooth.

Let me know if you have any ideas. I appreciate it.

  • 10 months ago
  • 1 point

I checked the 'Cleartype' settings in 'Fonts' and it was selected. Still no luck.

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube