add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Won’t display and red light

xlicex21
  • 9 months ago

Hi guys got. A problem right now first build. B450 won’t display and red light cpu :(

Comments

  • 9 months ago
  • 2 points

Could you please clarify little a bit more? Please share your part list because the one I see on your profile only shows a Ryzen 7 2700 and MSI's X470. Sounds like though if your red LED is glowing as the CPU then it's an indication to be an issue with the CPU. Assuming you have a Ryzen processor, carefully check for any bent pins. May need to gently fix bent pins with a pair of tweezers if able to, otherwise return it.

  • 9 months ago
  • 1 point

you should be able to bend the pins back

  • 9 months ago
  • 1 point

Yes, majority of the time. Unless the pins were bent too much and came off then that's a pickle.

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube