add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Anything wrong?

slarson651

7 months ago

https://pcpartpicker.com/list/PrjQXP

Just finished building this. At first everything seemed fine until I started to play games.

Ark, sounds would play.... Computer reset right away. Read some forums edited some file and it worked.

Star wars battlefront 2:. Clicked play, loading circle on mouse and it would just go back to Origin screen with the play option. Reset computer, then it worked. Sometimes.

GTA V missing dll file. Fixed that. Tried again and it says it unexpectedly shut down. Cant figure it out.

Every issue is all over the place which makes me thing stability but no idea. Was thinking about that power supply but it should have been enough....

Any thoughts? Thanks in advance.

Comments

  • 7 months ago
  • 1 point

Is your system shutting off altogether or is the game crashing to desktop?

I've had systems brown out upon putting them under sufficient load e.g. gaming, that would run fine to surf the web, type a letter, etc. If that sounds like what you have, then its your PSU... you either need a new one or a bigger one.

I generally aim for double the wattage I will need, as I know as a PSU ages it degrades producing less power. If you put in a PSU that only just does the job your gonna have problems sooner rather than later.

  • 7 months ago
  • 1 point

That PSU should be more than enough. I’d run some memory and cpu stress tests, maybe reseat the memory. Install hwinfo64 and make sure cpu and GPU temps are ok.

  • 7 months ago
  • 1 point

Thanks for your assistance. I am ordering a new PSU at a higher capacity just to be on the safe side. It was only $20 more so not a major issue.

Otherwise- things seem to be working better now. Each game I had required extra troubleshooting I found on youtube to just make them work. It was frustrating because I had not had so many unique issues happening like this on my past rig. I'm used to it 'just working' with no extra steps.

Thanks again!

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube