add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

New Ryzen 5 3600 ITX Build issues

csi_morris
  • 7 months ago

Okay so I've just built a new ITX and am I am experiencing a strange mix of issues.

1) The power button turns on the PC but holding it does not shut it down

2) I can't get a signal to display from either the HDMI or displayport on either the motherboard or graphics card

I am using a Ryzen 5 3600 with a B450 Aorus Pro Wifi Motherboard. The gpu fan and cpu fan starts up fine.

If anyone has experienced similar issues I would appreciate advice, or if anyone can help narrow down what the issue is.

I have already tried to clear the CMOS and have checked cables. I am wondering if the mobo needs a bios update for the new ryzen gen.

Cheers

Comments

  • 7 months ago
  • 2 points

Motherboard needs to be updated for the CPU.

Also ignore the motherboard outputs that CPU doesn't have integrated graphics so nothing is going to work out of them.

  • 7 months ago
  • 1 point

Got it working man thank you!

  • 7 months ago
  • 1 point

Looks like you need F40 BIOS version the bad thing is you must have a working PC to update the BIOS on that board. So either buy a cheap processor that is supported or try a PC shop.

https://www.aorus.com/product-detail.php?p=804&t=53&t2=57&t3=121

  • 7 months ago
  • 1 point

Yeah I bought a Ryzen 3 1200 and have now updated the bios to F40 so it is recognizing the 3600. Cheers!

  • 7 months ago
  • 1 point

Hi there!! I have the exact same motherboard and processor and the EXACT SAME PROBLEM.

Looks like all the inventory has old outdated BIOS that doesn't boot / post with Ryzen 3rd Gen. I will avoid Gigabyte from now on.

Your options are:

1a. Return for refund (since it doesn't actually work as-shipped)

or

2a. Contact Gigabyte and try to get them to RMA it so they can update the BIOS

2b. If they won't do it, AMD will send you a free loaner kit to update the BIOS using an older CPU.

  • 7 months ago
  • 1 point

I managed to get the motherboard to recognize the cpu! I had to buy an older generation ryzen then update bios to F32 then to F40.

Give it a try, it's not too difficult!

  • 7 months ago
  • 1 point

Their not old outdated BIOS you will have the same problem with any B450 board that was not made after the new processors were released.

  • 7 months ago
  • 1 point

EXACT same issue here. 3600x in a b450 aorus and I already sold my old cpu lol so pc shop it is

  • 7 months ago
  • 1 point

Good luck to you man, all my local shops were out of ryzens so I had to grab a 3 1200 to get the job done! I've finally sorted all my issues now though.

[comment deleted by staff]

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube