add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Should I RMA my MSI 290?

mzimmerman23

68 months ago

I got a new MSI R9 290 2-3 weeks ago, and i'm still having driver issues (my pc worked fine for 2 months before install). My computer restarts randomly while doing anything- browsing internet, games, word processing, system idle. This is my first graphics card, but I've used AMD's clean uninstall utility to remove all traces of AMD, and also I've reset my computer from a system image dated before the install, to install the fresh drivers, and it still has problems. I've tried at least 4 different driver packages multiple times from AMD, including the Beta, but none have worked. Recently, during FurMark, my gpu suddenly drops framerate, and the temperature drops too for a second, then regains itself. I'm pretty sure its not my power supply, a CX600M, and nothing is above its normal temperatures according to FurMark, HWMonitor, and MSI Afterburner when it was installed. Also, I've uninstalled anything Realtek on my computer, and played with every setting in bios to ensure my mobo graphics were off--- Nothing Works!!! I even messed with having audio turned on or muted. Right now, the backup Microsoft graphics adapter works more reliably (but doesn't let me play games). Thanks for listening to my probs, help me PCPartPicker Wizards!!!

Edit: I've RMA'd it and the new one works perfectly, Thanks for your help!

Comments

  • 68 months ago
  • 1 point

Have you tried the 290 in a different PC?

  • 68 months ago
  • 1 point

I would, but don't got another one. Want to donate? ;) I was also thinking to try it on my tv to see if it has to do with my monitor.

  • 68 months ago
  • 1 point

I would....for the right price ;) I don't think it's your monitor though, since that wouldn't cause framerate drops or restarts. Any friends who have a pc around?

  • 68 months ago
  • 1 point

I might be able to arrange something. -thanks for the good idea.

  • 68 months ago
  • 1 point

I have been building PC's since pIII. Every time I had problems with random restarts it's usually the ram. Your computer wont restart because of a bad gpu, it would just stop showing video. It's either your ram mb cpu or hdd.

  • 68 months ago
  • 1 point

Well, my computer has been running fine for 2 months before the card, my only HD is a Samsung 840 EVO, but I could try different RAM soon. That could narrow it down to my MB or CPU (a water-cooled, non over-clocked 6350). So possibly Mobo for now...

  • 68 months ago
  • 1 point

Does your mb have integrated gpu? Take the card out and use that for a few days.

  • 68 months ago
  • 1 point

I might try that, but its completely stable with the Microsoft basic display adapter.

  • 68 months ago
  • 1 point

So then it might possibly be the GPU. You haven't overclocked the GPU at all have you? You dont have any older GPU's laying around i assume? Yeah id RMA that GPU.

  • 68 months ago
  • 1 point

No overclock and no other gpus... I'll most likely just send it back.

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube