add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

No display from GPU

rwddrifter18
  • 6 months ago

So I believe my gpu is broken. When plugged into computer I dont get power to my usb or any display coming from it. When I unplug it and use onboard graphics it starts up fine.

I tried a new Power supply, and a different GPU and with the 2nd gpu it works fine. The (broken) gpu doesn't not work in a different computer same problem.

System: CPU: i7-6700k motherboard MSI z170A gaming M5 ATX GPU: Sapphire Radeon HD 7950 3 GB PSU: Corsair CX 500 W

Could there be a different problem or is it for sure the GPU?

Comments

  • 6 months ago
  • 1 point

Sound like you are right, it's a bad GPU.

  • 6 months ago
  • 1 point

i believe thats quite a bottleneck anyway. If its somehow in its warranty you can RMA it but otherwise as others say you will need a new GPU

[comment deleted]

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube