add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

RM550X corsair psu not passing power

banga

6 months ago

One of the switch pins is burnt could be the switch the problem? if one pin is broken it doesn't ship power? Or the psu is dead? I couldn't smell any burns smell in the psu itself only a bit and its not noticeable on the power plug should I change the plug? Or the psu is dead?https://imgur.com/wyPGA6b

Comments

  • 6 months ago
  • 1 point

What switch are you talking about? If it's the momentary-on power switch in the case, having a pin burnt probably means the switch is dead; but one would also have to ask how that happened. It's likely that something else failed or shorted, leading to overheating of the switch or switch leads.

  • 5 months ago
  • 1 point

To be honest the cable was plugged on the psu plug was loose when I moved the cable I heard sound of electricity but It was working fine before just atfer the lightning it did it once and stopped working. Is there hope on repairing the psu? Could it be saved by changing the plug ? Here is the picture https://imgur.com/wyPGA6b

  • 5 months ago
  • 1 point

That is burnt from heat caused by the loose connection. Look at the power plug it should look the same at the same plug(the cable that goes from their to the wall) You could try replacing the power cable and see if the PSU works. If not you will need a new power supply unless your skilled enough to replace the burnt plug (not sure where you would find one even)

Don't expect them to warranty the power supply not their fault the plug was not connected securely.

  • 5 months ago
  • 1 point

It was loose since first day it's my fault that I didn't send it back. I tried the cable on a monitor and it worka fine and yes it's burnt little bit also. I tried another cable psu didn't work. Tried a cheap psu and it powered the pc. The psu got damaged. I am not skilled with repairing I can only build pcs xD. Anyway I will try to find a good technicien. If there's no hope I will buy new one and keep it aside untill I relair it. I like it so much 0 noise it so damn good **** me for being retarded...

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube