add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Power on - No display

mjatwood
  • 6 months ago

Hello,

First time building comp: https://pcpartpicker.com/guide/t2wrxr/modest-intel-gaming-build

PSU fan turns on Mobo fan turns on

no display :(

Comments

  • 6 months ago
  • 1 point

Monitor cable plugged into the GPU, not the motherboard?

In order: Double check PSU connections for correctness and full seating, especially the 8-pin EPS power connector from PSU to motherboard, also 24-pin ATX connection. Re-seat RAM and GPU. Disconnect all hard drives and SSD and try again. Pull all but one RAM stick and try it in each DIMM slot, then the other RAM stick. Carefully pull CPU and double check for correct orientation and no bent pins.

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube