add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Unusual issue. Please help.

Brycet357

5 months ago

So I recently built my computer. I didn't buy cheap parts but I have a weird problem. On some apps it seems like processing takes a **** and is very laggy with mouse movements, it's hard to explain. On some loading screens for games it seems super choppy, but when I get into game it is super smooth. Also sometimes I have a weird issue where on the desktop, my mouse pointer will be distorted or turn into weird things. Sometimes it's a weird line. I'm wondering if maybe it is a problem with my I7-7700k. Please help!

Comments

  • 5 months ago
  • 1 point

Do you have the settings set to native resolution for your monitor?

  • 5 months ago
  • 1 point

Yes it is, 2560x1440

[comment deleted]
  • 5 months ago
  • 1 point

I have a parts list under my completed builds labeled "First Build!" Windows update has been ran and I also have Driver Booster 6 to check all drivers. Is there another way I need to check if drivers are up-to-date? I have my monitor connected to my GPU by DP cord.

[comment deleted]
[comment deleted]
  • 5 months ago
  • 1 point

First time using the OS on my M.2 SSD for my newly built rig.

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube