add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Half of my motherboard not getting power? (New build)

An_Edit
  • 5 months ago

Case LEDs, fans, and power button all work. Fans all work. So the motherboard is getting power. My RAM wasn’t lighting up (one lit up after), no USB power, no display.

I figure its probably something not fully plugged in, but I’ve never done this before. A thought I had was, the one corner of of my mother board isn’t attached to the case/standoffs (that corner is on the “half” of the mobo that isn’t working). I put the standoffs where my case said. But, there is what appears to be another spot in both the motherboard and the case for a standoff to go. I don’t know if that could be what’s causing this issue. Thank you in advance for any help.

PCPartPicker Part List

Type Item Price
CPU AMD Ryzen 5 2600X 3.6 GHz 6-Core Processor $224.85 @ Newegg Canada
Motherboard MSI B450M GAMING PLUS Micro ATX AM4 Motherboard $138.97 @ Newegg Canada
Memory G.Skill Trident Z RGB 16 GB (2 x 8 GB) DDR4-3200 Memory $146.88 @ Amazon Canada
Storage Samsung 860 Evo 500 GB 2.5" Solid State Drive $101.68 @ Amazon Canada
Storage Western Digital Caviar Blue 1 TB 3.5" 7200RPM Internal Hard Drive $61.58 @ Vuugo
Video Card MSI GeForce GTX 1660 Ti 6 GB VENTUS XS OC Video Card $437.27 @ Amazon Canada
Case Fractal Design Focus G ATX Mid Tower Case $80.21 @ PC-Canada
Power Supply Corsair TXM Gold 650 W 80+ Gold Certified Semi-modular ATX Power Supply $124.28 @ Amazon Canada
Monitor Acer XF240H 24.0" 1920x1080 144 Hz Monitor $337.30 @ Vuugo
Prices include shipping, taxes, rebates, and discounts
Total $1653.02
Generated by PCPartPicker 2019-09-12 10:59 EDT-0400

Comments

  • 5 months ago
  • 2 points

Do you have both the 8 pin and 24 pin power connectors plugged into the motherboard, monitor plugged into the video card.

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube