add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

First time pc build no power please help

AgingFawn88
  • 4 months ago

I built a new build pc for the first time it all powered on and I entered the Bios ready to install windows until I realised I had not connected power to the SSD. So I shut it all down disconnected the power and connected the SSD. I also reinstalled the graphics card at the same time in order to tidy up some wires. Once all connected I then go to turn on the PC but there is no life to it. I have tried disconnecting the SSD and GPU and still no power. Spec is as follows. Ryzen 7 2700 Asus Rog Strix b450f 2x 8gb Corsair Ram MSI rx850 GPU Corsair vs650 psu Samsung 500g SSD Any help would be massively appreciated as I don’t know where to go from here.

Comments

There are no comments.

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube