add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Mobo not working

MeighDay
  • 3 months ago

So I am doing a new build and PSU passes paperclip test but when I try to test the motherboard nothing happens. No fans, lights or anything. The light in the GPU turns on but that’s it. I am fairly new to all this. I took everything out and am now just testing the mobo and the psu alone. PSU turns on during paperclip test but when I plug it all into the mobo and touch the power pins with a screwdriver nothing happens. Any advice would be appreciated. I’m really hoping I’m just missing something and it’s not a doa.

https://pcpartpicker.com/list/Tbnjp8

Comments

  • 2 months ago
  • 1 point

So when you go to turn the mobo on with power supply, CPU and RAM connected nothing happens. This could be due to the CPU headers not being connected properly as some systems will not turn on without CPU detection, your front panel connectors are not in properly or you haven't connected the PSU to everything properly.

  • 2 months ago
  • 1 point

Have you plugged in all the power cables for the motherboard and not just the 24pin cable, there should be an auxiliary cable that either has 4 or 8 pins to connect to your motherboard as well... it seems your motherboard has both a 4pin and 8pin socket up the back corner near the IO ports.

Perhaps you need to get an adapter to plug into both those sockets as well, your motherboard manual is very unclear and just shows a picture on page 8 with no explanation whatsoever.

  • 2 months ago
  • 1 point

Thanks for the replies. I ended up trying a fully modular PSU and the mobo turned on so I guess it was just incompatibility with the PSU and the mobo.

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube