add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

RGB Fans not lighting up

tylerblane

2 months ago

Hi Everyone,

I've recently built a new computer and I purchased this case for my build https://pcpartpicker.com/product/8wXnTW/cooler-master-masterbox-mb520-rgb-atx-mid-tower-case-mcb-b520-kgnn-rgb. Every seems to be working well except for the front fan lights. While I have the fans functioning on the case, the lights are not working. I've also got 2 extra fans on the top and the lights seem to be working on those two. I've got the rgb adapter that came with the case which we've used along with other cables. Motherboard I'm using is gigabyte b365m gaming hd matx if that is any indicator... I'm a first time builder so not really sure where I went wrong along the process for it to be not working. Thank you!

Comments

  • 2 months ago
  • 1 point

RGB fans usually have a cable for the fans themselves and then one for the rgb if the RGB cable is not plugged in then it wont light. Some fans come with a RGB hub/controller you could plug it into or you can use the RGB ports on your motherboard if it has them. Hope this helps!

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube