add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Pc not displaying anything

anthonytran12
  • 2 months ago

Hello guys i just finished my pc everything turn on all the fans or working and for some reason i try to connect to my tv via hdmi it wont work there no display at all thanks for the help guys here my build

https://pcpartpicker.com/list/HGbLPn

Comments

  • 2 months ago
  • 1 point

Are you connecting the HDMI to the MOBO or the graphics card?

Is your TV set to the correct input for where you plugged in the HDMI cable?

  • 2 months ago
  • 1 point

I tried both the motherboard and graphic card and yes they are on the correct input i even tried to re do my memory but nothing work

  • 2 months ago
  • 1 point

If it help i also have another cpu pin i havent connected to the motherboard because i couldn't find the slot for it

  • 2 months ago
  • 1 point

Anyone??

  • 2 months ago
  • 1 point

Is the TV working for other things? ie. Shows, video game console, etc

What do you mean by another CPU pin? Do you mean a spare CPU to try or is something not connected?

It might be worth a try to remove the video card and reseat it in the slot.

If you have a friend with a video card, you could try that and see if the display works.

Your two most likely problems are a faulty video card or PCIe slot in your MOBO. If a spare video card works then it is the card, if not then suspect the MOBO.

  • 2 months ago
  • 1 point

Hello, make sure all cables are securely connected. And, I see on your build there is a 1660. Some 1660s require external power, so make sure there is external power going to your video card.

  • 2 months ago
  • 1 point

How do i do that man thanks?

  • 2 months ago
  • 1 point

If there is a plug on the front of your GPU (that looks similar to the one for your CPU on the MOBO) plug the PCIe cable from your power supply into it.

  • 2 months ago
  • 1 point

Alright thanks man

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube