add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Seemingly unreported MOBO/GPU physical incompatability

Genuine_Corncob

2 months ago

I'm not sure if I'm even qualified to be reporting this kind of thing, but I just used the "System Builder" and added the parts which I believe might be incompatible (from personal experience, less than 12-hours ago) but the only confliction mentioned at the bottom of the page was the standard "Make sure your CPU cooler has enough clearance for your RAM". That said, I'm unsure which forum this topic belongs in, so please accept an apology in advance because I'm confident that this isn't the right one. If someone would like to point me in the right direction for reporting a possible hardware confliction, I would be more than happy to repost this in the correct place.

Last night I finished retooling my build with a new [Gigabyte x570 Aorus Master] motherboard. I was planning on re-using my [Gigabyte Radeon Vega 64] GPU, but they don't seem to physically fit together. I can't be totally sure what's physically stopping the video card from being fully seated into the PCI-E slot, but no amount of force I can generate (and am comfortable applying) is enough to make the card click into place.

Close inspection shows that the metal contacts which I assume are supposed to be completely protected by the PCI-E slot are still exposed. Once I realized it wasn't correctly inserted, I took a zip-tie and used it to try to gauge the space between the GPU and MOBO and discovered that there seems to be enough space fit the card, but I just can't get it jiggered into position.

I took an old GPU I had sitting around from a previous build ([MSI Radeon Cyclone 6850]?) and successfully slotted it in to the PCI-E slot with literally no resistance at all, which leads me to believe the [Vega 64] and [x570 Aorus Master] might not actually be compatible.

Comments

  • 2 months ago
  • 1 point

Can you provide pictures? They should be compatible.

  • 2 months ago
  • 1 point

They are compatible. It one of two things. First, there is some physical damage or de-formation that is not allowing the GPU to be inserted. Second, it just a tight fit and need a bit more force perhaps a uncomfortable amount. It happens sometimes.

  • 2 months ago
  • 1 point

This topic has been moved from "General > General Discussion" to "Systems > Troubleshooting".

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube