add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

MSI H81M-P33 with Haswell Refresh CPUs... has anyone made it work?

therfman
  • 72 months ago

Hello,

I'm wondering if anyone here has built a system using a MSI H81M-P33 motherboard with a Haswell Refresh CPU. I'm putting together a budget build for a client, and I bought a Celeron G1840 to go with this motherboard. MSI says it is supported as of BIOS v 1.4, but there are issues.

Essentially, the computer will not restart. Not from Windows, not even from the BIOS upon exiting. It just hangs on a black screen. I also tried with a Core i5-4460 I had, and it also hangs with that CPU on restart. Having also swapped the RAM and tried with an external GPU, I gave up and exchanged the motherboard. The new one does the same. Shutdown and cold boot is fine, but not a restart.

So I decided to pull the only original Haswell CPU I have around (a Xeon E3-1230v3) and try it in the H81M-P33. It works fine and restarts no problem. So it looks like the Haswell Refresh CPUs are not totally well supported on this motherboard. I've already lost a lot of time on this build, and now I need to change either the motherboard or CPU.

I'm not too impressed with MSI.

Comments

  • 60 months ago
  • 2 points

Sorry this is a bit late, but were you able to install BIOS 1.5 with the i5-4460 installed, or did you have to use an original Haswell CPU to install it?

  • 60 months ago
  • 1 point

I have the same doubt, I'll get the same CPU/MOBO and I don't have a compatible processor with that socket.

  • 72 months ago
  • 1 point

If applicable, You can try the most recent version. MSI has BIOS version 1.5 available for download.

  • 72 months ago
  • 1 point

Yes, this was released overnight, I have tried it this morning and it has solved the problem. I still think MSI should not have claimed compatibility with BIOS v. 1.4.

  • 60 months ago
  • 1 point

How I wish there was a "MARKED AS SOLVED" button..

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube