add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Antec Case Vs Motherboard issue

refugeesus

58 months ago

Hey all,

I am looking to upgrade my rig, but want to salvage some parts, but when I go to combine the Antec Nine Hundred Two case with the ASRock Z97 motherboard, I get the following message;

ASRock Z97 Anniversary ATX LGA1150 Motherboard has onboard USB 3.0 headers, but the Antec Nine Hundred Two ATX Mid Tower Case does not have front panel USB 3.0 ports.

Does this mean I can still use the USB ports as 2.0 or something else entirely?

Cheers in advance.

Comments

  • 58 months ago
  • 1 point

it means that your case has no front panel USB 3.0 slots. it pretty much means you can still use the case, but you wont be able to use the USB 3.0 slots on your motherboard.

  • 58 months ago
  • 1 point

Cool. I can live with that. I should be able to use them for 2.0 though, right?

  • 58 months ago
  • 1 point

if the front of the case has USB that is not 3.0 then yes. if there is no USB on the front of the case at all, then you will need to use the USB slots on from the motherboard on back of case.

  • 58 months ago
  • 1 point

Thanks, there are 2 usb slots on the front of the case, just not 3.0.

  • 58 months ago
  • 1 point

I should be able to use them for 2.0 though, right?

  • USB 2.0 headers are not the same as USB 3.0 headers.
  • Read your mobo manual.
  • 58 months ago
  • 1 point

I get that they're not the same, I was wondering if they were backwards compatible.

I don't have the manual at hand. It's about 6 years old and has been misplaced. I'm not even sure of it's name. x58 something or other

I'll do a google search.

  • 58 months ago
  • 1 point

? Read your ASRock Z97 mobo manual. Unless you intend to use previous mobo.

  • 58 months ago
  • 1 point

I haven't purchased it yet. I was looking at the compatibility issue. And disregard the x58 mobo. That is my current one. I confused my self. Lol It's the case that's the issue, not the old mobo.

  • 58 months ago
  • 1 point

No problem. You can still use USB 2.0 port.

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube