add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

my story of how phantek ruined my day.

jakethemp

78 months ago

so im looking around for a new CPU cooler, one that looks great and matches my blue fans, blue mobo and still has a good look, behold the phanteks ph-tc14pe, blue edition. so I order this bad boy a week ago, im watching the tracking waiting for this thing to get here. it finally comes today and i've got my whole system stripped vid cards are pulled out, cleaned all my fans, cleaned up the cpu for the new cooler. it finally gets here at 2pm. so first thing I notice is I cant put the back plate in without taking out my motherboard. Ok, cool I guess I saw that coming. so I finally get the back plate mounted, PHEW that took some finesse. check and make sure the cooler clears my ram... YUP were good there. I go to bolt the plate down that secures the cooler... HOME STRETCH!!!!!!! and low and behold the gawd damn MFin screws that bolt into the mounts were more than half a screw width off. so I mess with it for another 10 min. "check and see if I had the wrong socket screws" nope everything is the way it should be. and once again I try for almost 20 min to line these screws up. and lock this bad boy down. Its not happening. I thank the man upstairs with blessing me with mechanical common sense. so I go to my tool bench and drill next to the screw hole I just removed the tension screw from and make it so I can adjust the screw to the correct position. it works!!! I clean the burrs off the metal go back in and mount it up. FINNALLY! 2 hours later I get this beast mounted, fans mounted up, and everything kicking ***.

this is just my little vent to guys who know what I have dealt with. Just pisses me off I had to modify my 108$ (after shipping) aftermarket cpu cooler that is supposed to be top of the line.

all said and done and problem solved the cpu cooler works great im seeing 26c temps at idle almost 4c cooler than the enermax cooler I had in there an its very quiet.

all in all I rate the finished product a 10. def not for the novice first timer to attempt without an extra hand.

Comments

  • 78 months ago
  • 1 point

How's that Phanteks fault?

And it looks like you got it figured out, I would say that it was successful.

  • 78 months ago
  • 1 point

if they screws lined up perfectly and fit the first time it would have been great. it just pretty much took all day to put this thing on. and yes it turned out alright. it was a machining mistake on phanteks part.

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube